WordPress官方建议使用Apache或Nginx作为运行WordPress的网页程序,但是任何支持PHP和MySQL的服务器都可以配合其他网页程序运行WordPress。

WordPress 软件为每个人而设计,强调无障碍、性能、安全和易用。我们相信,伟大的软件应在较少的设置下就能运行,这样您就可以专注于自由地分享您的故事、产品或服务。基本的 WordPress 软件简单易懂,所以您可以轻松上手。其还为发展和成功提供了强大的功能。

WordPress

WordPress 官方建议配置

要运行 WordPress,我们建议您的主机支持:

  • PHP 7.4 或更高版本。
  • MySQL 5.6 或更高版本或 MariaDB 版本 10.1 或更高版本。
  • HTTPS 支持

WordPress 官方建议使用 Apache 或 Nginx 作为运行 WordPress 的网页程序,但是任何支持 PHP 和 MySQL 的服务器都可以配合其他网页程序运行 WordPress。

注意:如果您处于只有旧版 PHP 或 MySQL 版本的旧版环境中,WordPress 也适用于 PHP 5.6.20+和 MySQL 5.0+,但这些版本已达到官方生命终结,因此可能会将您的网站暴露给安全漏洞。

泪雪推荐配置

  • 推荐配置 PHP 7.4+搭配 MySQL 5.6+ 或者 MariaDB 10 +
  • 基本配置 PHP 5.6.20 + 搭配 MySQL 5.0+
  • 网页程序推荐 Apache 或者 Nginx

需要注意的是,MySQL 5.6 及以上的版本对内存使用会比 MySQL 5.0 的要高很多,建议服务器的内存为 1G 以上,如果只有 1G 或者不足 1G,可能会安装失败。

购买服务器注意事项

从上面的配置信息可以看到,最基本的要求是 php 5.6 和 mysql 5.0 以上,满足这个配置的话,512MB 内存的 VPS 都可以安装,并且能够正常使用。

但是出于安全和性能考虑,推荐购买内存大于 1G 的 VPS,这样可以安装 MySQL 5.6+ 或者 MariaDB 10 +的数据库,性能更好。

同时如果你需要搭建商城系统,WooCommerce 插件对系统要求也比较高。当然如果你的网站和我们泪雪网或垒阅网达到一定流量的时候,就需要考虑上单独的云服务器和针对性的 WordPress 优化了,这样才能够让 WordPress 运行更加稳定和快速。

0个人收藏 收藏

评论交流

泪雪默认头像 请「登录」后参与评论
  1. 加载中..

相关推荐